Welcome to the Soartex forums!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the Soartex Forums! Consider signing up to get involved!
  3. Registration has been temporarily disabled until we sort out the issue regarding spam on the forums. Sorry about this!

Resolved Weird Lines on Tall Flowers

Discussion in 'Bug Reports' started by arturwt, Nov 24, 2015.

  1. arturwt

    arturwt New Member

    Hello! I'm experiencing some issues, here's my MC's and Mod's Versions:

    Minecraft 1.7.10
    Soartex Fanver V2.7.4
    OptiFine v1.7.10 HD U C1

    There are these weird "X crossed" lines over the 2 block flowers, took some SS:
    It doesen't look like much here, but it's just a matter of angle and distance.
  2. artdude543

    artdude543 Lead Administrator / Mad Modder Staff Member

    I can't reproduce this in Vanilla. So I'm guessing Optifine is doing some funky things again.
  3. Valsis

    Valsis Lead Fanver Developer Staff Member

    Just downloaded this Optifine version to test it and I cannot reproduce this at all even after messing up with all the settings from the mod.
    I tried to check the same blocks and angles you posted and I cannot see any of these random pixels showing up.

    I must say this might be an isolated case since the team cannot reproduce this visual glitch.

    Best regards,
  4. travkliewer

    travkliewer Well-Known Member

    I'm having the same problem. Here are some screen shots.
    This second on I have shaders on to show that something is getting rendered that shouldn't be there.

    I can solve the problem by increasing the an-isotropic filtering, but I can't use that with shaders. So, I'm thinking the problem must be with the video card or our specific settings. We should compare notes and see if we can't figure out what's going on.

    Edit: Here's another one.
    Last edited: Jan 12, 2017
  5. Valsis

    Valsis Lead Fanver Developer Staff Member

    Hey there @travkliewer
    Since you mentioned a possible conflict with your Graphics Card, try checking if the drivers are up to date.

    Also, what Shaders pack are you using and which version? This might also be a conflict with the Shaders pack itself when used as I've seen that happen.

    Also, if you're using Optifine, make sure you're using the latest version for the Minecraft version you'rep laying in.

    Best regards,
  6. Valsis

    Valsis Lead Fanver Developer Staff Member

    Little update, I took the time to look into the pack again and I still cannot replicate the issue.

    Here follows an album with some screenshots to support my claims. Three of them will be purely vanilla with no Optifne or Shaders and, the other three will have Optifine and Shaders.

    Keep me posted on your graphics card theory as our team is not being able to replicate this issue at all.

    Also, if possible @travkliewer what are your computer specs?

    Best regards,
  7. Shoeboxam

    Shoeboxam Administrator/ Invictus Staff Member

    There are two problems here. One comes from your graphics settings, and the other from mipmapping interpolation.

    First, white lines: this tends to be an issue on NVIDIA graphics cards/drivers. Right click on your desktop, and open NVIDIA control panel. Go to 'adjust image settings with preview.' Enable 'let 3D application decide.'

    Second, mipmapping interpolation: I have experienced this issue with older minecraft versions. The issue comes from the fact that mipmapping creates copies of the texture at lower resolution, and displays those textures at distances further away from the player. In order to make lower resolution textures, the game takes a number of pixel samples around any given point inside the texture file. Interestingly, when the game samples pixels around the very top of the texture, some samples wrap around and grab data from the bottom of the image. I fixed this in Invictus by lifting the grass texture from the bottom of the png file. These issues can crop up occasionally in Fanver because Fanver never added these mipmapping tweaks.

    Let me know if this helps!

Share This Page