Welcome to the Soartex forums!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the Soartex Forums! Consider signing up to get involved!
  3. Registration has been temporarily disabled until we sort out the issue regarding spam on the forums. Sorry about this!

Tutorial Texture Patcher Guide

Discussion in 'News & Discussions' started by Shoeboxam, Jul 7, 2013.

  1. Shoeboxam

    Shoeboxam Administrator/ Invictus Staff Member

    If you have any problems, be sure to let us know!

    Step one: Download and start the patcher.
    Won't open? (open)
    Be sure to start it with Java! Most people don't need this extra step.

    Step two: Select your version of Minecraft in the popup.

    Step three: Choose the mods you use

    Step four: Browse to your texture pack
    If you don't have Soartex yet, the "Download Pack" button fetches one.

    Step five: Patch!
    Clicking this button will download the latest mod textures for the mods you chose and add them to your texture pack. Have fun!


    Bonus feature: Facelift your pack!
    Have you updated your mods since the last time you patched Soartex and want new textures for them? Open the patcher and check for updates. This is an extremely easy way to maintain a texture pack for your game.

    Bonus feature: Presets
    Presets are available for popular mod packs from the files dropdown on the top left. It changes the checkboxes to match those packs.
  2. Free_Byrd

    Free_Byrd New Member

    When I try to run the patcher it tells me "The externalconfig.txt file is the default" and I get a notepad file in my downloads folder that says this every time I try to run it:

    [05:01:19] [SEVERE] The externalconfig.txt file is the default!
    net.soartex.texture_patcher.Texture_Patcher_Exception: The externalconfig.txt file is the default!
    at net.soartex.texture_patcher.Texture_Patcher.loadConfig(Texture_Patcher.java:316)
    at net.soartex.texture_patcher.Texture_Patcher.run(Texture_Patcher.java:137)
    at java.lang.Thread.run(Unknown Source)
  3. grav0r

    grav0r Well-Known Member

    For me its the same..
    The externalconfig.txt file is the default!
    Though i read alot in your wiki and made a own externalconfig.txt, still not working. Win8Pro, newest java, no other problems.. just texture patcher wont start.. please help :)
  4. GoldBattle

    GoldBattle Administrator Staff Member

  5. PoloTiger

    PoloTiger New Member

    I love using the patcher, but I have a problem.

    I have a custom pack with a bunch of friends on a private server. Since I love Soartex I use the patcher to make make it easy to get most, if not all the textures I want for the mods we play with. Sadly, the patcher doesn't have MFR in it, but I have found an MFR pack in the forums.

    The questions I have are:
    1. How do I add the file with the MFR textures in it to the Patched texture pack?
    2. How do I add the animations if I have a file for them?
    I have already tried just opening the Texture Pack folder and placing the MineFactoryReloaded file in the folder, but the textures never register.
    Any and All help is welcome and thank you!
  6. GoldBattle

    GoldBattle Administrator Staff Member

    The reason that they are not yet on the patcher is because they have not been updated/converted. The textures on that thread are for a very outdated version of the mod. Until someone comes along and converts those old textures to the new version of the mod, they will sit there. The way they can be converted is by taking the old textures and matching them up with the new version of the mod.

    Here is a guide about updating textures:
    • Download the new version of the mod
    • Extract the /assets/ folder from the mod.jar (using 7zip or something)
    • You need to place the old textures where the new ones are
      • This will cause a problem because the old texture is a huge file with multiple images in it, while the new ones each file just has one texture in it.
      • So you need to cut out those small individual textures so they correspond with the new textures
    • All paths and names need to match i.e. /assets/minecraft/blocks/diamond.png
    • Once you have this you should be able to add the files to your texture pack.
    • You will know you got the paths right and the files correct when you load up your game and the textures are replaced.
    • You can reload all the texture ingame without restarting by pressing f3+t
    Now if you are not up to converting the textures from that thread yourself to be compatible with the new mod version, if you post in the MFR thread I am sure there are people around that will be willing to do that for you. Hope this helps

    Edit: You might also want to check out the 1.5.x version of the textures. If you just rearrage these files around you should be able to get most textures working. Just make sure that the paths to the files in the mod.jar match the files in your texture pack. Here is the link to the 1.5.x download:
    http://files.soartex.net/archives/MC 1.5.x/mods/Minefactory_Reloaded.zip
  7. PoloTiger

    PoloTiger New Member

    Basically are you saying take the texture files from the 1.5.x version and put them where?
  8. GoldBattle

    GoldBattle Administrator Staff Member

    Move and rename them to match the 1.6.x version files.
  9. PoloTiger

    PoloTiger New Member

    Thanks for all the help and patience. Your a real great staff member, and truly show how this pack has lasted so long with the help of the community and people like you!
  10. GoldBattle

    GoldBattle Administrator Staff Member

    No problem, make sure you post in the MFR thread to try to get some help from others with updating.
  11. EpicUltimatrix1

    EpicUltimatrix1 New Member

    Um, the page with the download link won't even open for me. I tried this how many times, and it didn't work.
  12. Valsis

    Valsis Lead Fanver Developer Staff Member

  13. EpicUltimatrix1

    EpicUltimatrix1 New Member

    Okay, it works, but it's taking over an HOUR to patch! Is this normal? The mods I selected are Biomes O' Plenty, Mystcraft, and Tinker's Construct.
  14. Shoeboxam

    Shoeboxam Administrator/ Invictus Staff Member

    This is not normal, our file server is currently under some unusual stress, but it should be resolved soon. Let me know if you have any more problems with it though. :D
  15. Vincent

    Vincent New Member

    I have java 1.7.0_45 installed, but when i tried to open the patcher file it said couldn't found java, and then tried to download but java version 1.6.0. Is there anyway i can tell it to use my 1.7.0 java?
  16. Adron20

    Adron20 New Member

    Sorry if this content is anywhere else, but i can´t find it.

    I´ve been using the 1.2 texture patcher lately, but now i got an error when i try to launch it. I tried using the v2.2 but I can´t launch it either. On the download page you can read: Remember, you have to set-up the configuration first, this jar wont launch without any changes! Read the wiki!

    But there is nothing about this on the wiki (at least i cannot find it). I´m seeing the configuration guide, but it says that it´s made for artists and I´m that average Joe who would like to use the usage guide. What is the needed set up?

  17. Valsis

    Valsis Lead Fanver Developer Staff Member

  18. ECHO207

    ECHO207 New Member

    Thanks Val for that try, I as well was trying to get something to work via the new patcher. From your link and running that 2.1.jar I got:
    java.io.IOException: Server returned HTTP response code: 403 for URL: http://soartex.net/texture-patcher/data/branches.json
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    at java.net.URL.openStream(Unknown Source)
    at net.soartex.texture_patcher.TexturePatcher.loadModBranch(TexturePatcher.java:113)
    at net.soartex.texture_patcher.TexturePatcher.run(TexturePatcher.java:58)
    at java.lang.Thread.run(Unknown Source)
    Fun fun fun, TiA
  19. GoldBattle

    GoldBattle Administrator Staff Member

    Yep, so we are having a problem with the patcher since the webserver move. We have started looking into it, and are trying to come up with solutions. For now, I would recommend downloading the latest universal builds from the modded page: http://soartex.net/downloads/modpacks/

    Thanks for being patient!
  20. artdude543

    artdude543 Lead Administrator / Mad Modder Staff Member

    Hey, could you please try this version hopefully this fixes the bug with the current version of the patcher: http://dl.soartex.net/1gakr
  21. ECHO207

    ECHO207 New Member

    It worked! Thank you very much artdude543. Excellent job! :)
  22. Adron20

    Adron20 New Member

    @artdude link worked for me too. Thx!
  23. Vel Thraytor

    Vel Thraytor New Member

    All this Seems to work fine for me except for the Divine Rpg addon, the stupidest part about it is that all the texture addons for the other mods i have work fine, so why is it that one of my mods are still in default textures?

    Did i do something wrong or is the pack just being Stupid.

    What confuses me even more is when i go into the texture pack and go to the specific custom mod textures. All of it is there and its not in default Minecraft textures.

    If anyone can help it would be greatly appreciated :)

Share This Page