Welcome to the Soartex forums!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the Soartex Forums! Consider signing up to get involved!
  3. Registration has been temporarily disabled until we sort out the issue regarding spam on the forums. Sorry about this!

Resolved Soartex Modded- modded textures not showing

Discussion in 'Help & Support' started by Aznagel, Nov 11, 2016.

  1. Aznagel

    Aznagel New Member


    First of all I'd like to thank the team for all the hard work you've done on this wonderful texture pack.

    I have a weird issue with Soartex Modded. I use it via the Curse launcher, Minecraft version 1.10.2

    So I've downloaded a few mods that I knew were re textured by Soartex ( Forestry, Storage Drawers ) + Optifine
    The Vanilla textures are looking fine but none of the new textures are modified by the Fanver pack. (wood textures, etc.)

    I've tried creating a new profile with minecraft 1.7.10 with only Forestry and the texture pack, and everything is showing juste fine. I've done the same with 1.10.2....but still no luck. So Optifine or any other mod doesn't seem to be involved in this issue.

    I know that this may be related to the mods themselves, Forestry has had an awful lot of updates and they are always in alpha for example.

    Or could this be related to the Curse launcher itself ? It seems that something is overriding the textures. Or is it a path problem ?
    I need to try without the launcher maybe...

    On a side note, I've seen that there are a good number of retextured mods in the 1.7.10 version that are not present in the 1.10.2. (Botania, Biomes of Plenty, etc ) Can I add them manually or does it require a bit more work/skill ?

    Sorry to bother you, I know your time is precious, but i'm clueless. Thank for any help I can get !

    NB : sorry if my english is a bit broken and if i am not a 100% clear, i'm not A native English speaker ;)
  2. Shoeboxam

    Shoeboxam Administrator/ Invictus Staff Member

    Your English is great!

    Our 1.10.x support is still young, and I haven't had the time to check through and verify everything is working/can be ported directly.

    I would download the 1.7.x universal pack and place it below the 1.10.x vanilla pack in the resource pack menu. Texture support should only be broken if the mod reorganizes its textures. Those mods that did a direct port of the textures should load the 1.7.x textures correctly, for the most part. I would expect many missing textures, but this can be a temporary solution as full support for 1.10 is still being worked on.

    The link to the 1.7.x universal pack is here:
    Just place it in the resource packs folder for your minecraft instance. The folder can be accessed from the resource pack menu in-game.
  3. Aznagel

    Aznagel New Member

    What can I say but..."thanks a million !" as we say in Ireland

    It's working. A few textures are still missing like you said but nothing compared to before. Yeah :)
    That's great, and keep up the good work, this texture pack is really impressive. I'd like to help but my skills are limited regarding coding. I might get a look on the tutorials to learn how to create textures>

    Thanks again
  4. Shoeboxam

    Shoeboxam Administrator/ Invictus Staff Member

    I started learning from scratch ~5 years ago because I wanted to learn how to make textures when Soar49 left. It's been a hobby of mine ever since. The folks here in the Minecraft community have taught me so much.

    Anyways, we're always looking for contributors, especially in modded.

    Progress is coming along on 1.10-
  5. Aznagel

    Aznagel New Member

    Great news !

    I'll have a look at the tutorials and try a few things, I'd like to learn how to actually do stuff, so let's do it :)
  6. Vel Thraytor

    Vel Thraytor New Member

    I seem to be having a similar problem but some of it just doesn't add up.
    For instance I'm using a few mods, Them mainly being: (all 1.7.10 Ver) Divine RPG, Twilight forest, and backpacks.
    What i did was use the patcher and make a pack that supports all 3 mods in one, compared to just having all 3 seperate.
    the most odd part is that when i load my game Twilight forest and backpacks seemed to have responded to the pack but Divine hasn't. The part i can't work out is why Divine Rpg is not accepting the new textures despite the fact it works for the rest.

    Have any clue what this might be?
    Many Thanks if help and solution is reached :)
  7. Shoeboxam

    Shoeboxam Administrator/ Invictus Staff Member

    My initial guess is that the path to textures in divineRPG has changed, and while textures are in your pack, they are in the wrong location. However, I cannot confirm without more information.

    Could you open your patched resource pack and check to see if this folder exists:

    If it does, then open the divinerpg mod itself with an unarchiver and check to see if this folder exists:

    If you have problems opening the mod file, then tell me what version of divineRPG you have, so I can check it.

    Let me know! Thanks.
    DrumMaster4 likes this.
  8. Vel Thraytor

    Vel Thraytor New Member

    Firstly thank you for the reply.

    1. To answer the first part the "assets/divinerpg/textures etc" exists. (in the Custom Texture pack)

    2. I'm assuming your asking me to open the .jar of the mod with winrar? if so then yes the assets/divinerpg path exists.

    3. And im running the 1.7.10 version.

    Though i dont know much about how texture pack pathways work, i was going to get the xolovron.pngs of the custom mod textures and throw them in the main folder of the texture pack and see if the mod responds, but i can't seem to find the updated versions of them.

    Sorry to trouble you with this. Im sure you a busy person who has other matters to attend to as well, The reply alone is a comfort though :)
  9. Valsis

    Valsis Lead Fanver Developer Staff Member

    No need to be sorry!

    We, as developers, have to be ready to face reports of things not working. With your help, it's also our job to find what's causing these issues and find a solution for it and provide you a way to fix it.

    Without us knowing that things aren't working as intended, there's no way we'll be able to fix it so, by all means tell us what isn't working every time you encounter an issue with our pack :)

    Best regards,
    DrumMaster4 likes this.
  10. Vel Thraytor

    Vel Thraytor New Member

    Appreciated, Any suggestions on how i may be able to locate the issue/fix it, im not sure whats causing it but so far my attempts on finding the issue have been void. If this is not too much to ask for is there a chance i could have the Xolvron.pngs of the 1.7.10 textures for divine, i want to put them in the main part of the pack and see if it warrants a response. Other wise i can provide you with what ever infomation you need and leave the rest to your care.

    Once again appreciate the response its a comfort to see some dedicated developers of a excellent pack :)
    Valsis likes this.
  11. Shoeboxam

    Shoeboxam Administrator/ Invictus Staff Member

    I had made ~500 textures for DivineRPG back in the days when we still used texture atlases. Looks like most never made it through the port, unfortunately.

    Here are the current assets in DivineRPG:

    And here are the current assets in Soartex Modded:

    The first thing I notice is that the assets in Soartex are uppercase. I'm going to assume that DivineRPG renamed their asset files to start with lowercase letters. There also appears to be some file shuffling.

    I'm working on a fix!
    --- Post Merged, Jan 22, 2017, Original Post Date: Jan 22, 2017 ---
    Alright, I've finished the port. I fixed the lowercasing with a script, and then checked through all of the files and renamed/deleted where needed. DivineRPG is now ported to 1.4.1. The changes may not appear on our website for a day or two until our packager runs, but I have attached the updated mod patch in this post.

    Sorry it took so long, there are just too many things to cover. We always need whatever help we can get on tasks like this.

    Attached Files:

  12. Vel Thraytor

    Vel Thraytor New Member

    Thankyou very much, I wish I had some skill in this so I could help. Keep up tithe good work :) and really appreciate this.
  13. Vel Thraytor

    Vel Thraytor New Member

    I placed the 'divineprg' folder from the zip into my main texture pack, but still no change did i miss something? Sorry to bother you with this :c
  14. Vel Thraytor

    Vel Thraytor New Member

    Never mind, dont reply to that i reloaded the game and the new textures work, Some of them at lest.
    Regards Vel

Share This Page