Welcome to the Soartex forums!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the Soartex Forums! Consider signing up to get involved!

Update How to fix CTM for Bookshelves in 1.9/1.10

Discussion in 'Bug Reports' started by White_Crafter, Dec 6, 2016.

  1. White_Crafter

    White_Crafter Well-Known Member

    Hello guys,

    I am a big fan and love Soartex, but yesterday I saw the bookshelf-problem again in the 1.9.4

    Idk if it is working for 1.10 too :) have not tested it yet

    Update: Working in 1.10 with 1.8 CTM Bookshelf too.

    I do not want to "disable" (deleting the bookshelf file in CTM) this feature, so I tested some things and I found (at my computer) a solution.

    Use the 1.8 CTM bookshelf, this is working perfectly :) if you change the file you will get again the comnected texture.

    To the admin/making team: Please start the support again, you can easily make a lite version... only deleting one file...
    I love the connected textures :(

    ~White_crafter
    Last edited: Dec 7, 2016
  2. Valsis

    Valsis Lead Fanver Developer Staff Member

    Hey there @White_Crafter

    The Fanver team decided to fully drop support for Connected Textures specifically for Bookshelves as we were having constant issues being reported with them all the time.

    Don't expect it to be back as we have no plans to bring it back.

    Best regards,
  3. White_Crafter

    White_Crafter Well-Known Member

    Okay, but 2 questions :D

    First, do you remove all CTM textures in the future :(

    I do not want to be impolite and I know how hard it is to make a texture pack with especially so less developer, but why can you not support CTM again? I know that therr are often changes because of Optifine versions, but there are not too many CTM blocks and do you really cannot do anything :/

    In my option, this is one of the best features in Soartex. It makes very often a better look.

    I understand it, if you have not the time for making it...

    Another question, will you make a 1.11 version?

    Thank you for all

    ~White_Crafter
    --- Post Merged, Dec 6, 2016, Original Post Date: Dec 6, 2016 ---
    You know, if you are using the 1.8 CTM of the bookshelf, it will work with all Optifine versions in 1.9 and 1.10 :)

    I tested it and try it, it works fine ;)

    ~White_Crafter
  4. Valsis

    Valsis Lead Fanver Developer Staff Member

    Hey again @White_Crafter

    We do support CTM on many other textures, and we're not going to remove them unless several people report issues with them.

    Previously we were constantly having people reporting issues with bookshelves to the point our Bugs Report section was filled with help tickets -just because of the bookshelves- . With this, we made the decision to remove CTM support all together solely for bookshelves which helped us save time to work on other things for the pack.

    CTM isn't easy to work on and make it work. For you it might look like it's easy because you're literally dropping files from an old pack to a newer one. However files do change. Settings do change. Optifine settings change every update as the Minecraft code itself changes for every update as well. This is the main reason why Custom Textures break, in this case, the bookshelves.

    CTM isn't easy. Having to check every update for broken configurations, including custom 3D models, which happen to be one of the hardest things for the 3D dev to do with the -no time available- he has, it's not an easy task so, we're doing our best.

    Also, It was posted in this forum that we're updating the pack for 1.11 and you can see that announcement in the Members's Status on the right hand side of the forum that you can see here, on our Twitter page that you can see here, on our official Minecraft Forum that you can see here and on our official Planet Minecraft page that you can see here.

    Best regards,

Share This Page